PRIST.RU [тема: Проблема при работе по TCP/IP с АКИП-1134-60-25] http://prist.ru Новое в теме Проблема при работе по TCP/IP с АКИП-1134-60-25 форума на сайте PRIST.RU [prist.ru] ru http://backend.userland.com/rss2 Thu, 16 Jul 2020 16:12:06 +0300 Проблема при работе по TCP/IP с АКИП-1134-60-25 Проблема при работе по TCP/IP с АКИП-1134-60-25 в форуме Программное обеспечение.
Здравствуйте.



Эти источники не имеют обновления прошивок.



Для решения проблемы попробуйте увеличить время между командами.

28.12.2016 10:15:49, Сергей Верижников.]]>
http://prist.ru/forum/messages/forum4/topic2236/message13303/ http://prist.ru/forum/messages/forum4/topic2236/message13303/ Wed, 28 Dec 2016 10:15:49 +0300 Программное обеспечение
Проблема при работе по TCP/IP с АКИП-1134-60-25 Проблема при работе по TCP/IP с АКИП-1134-60-25 в форуме Программное обеспечение.
Здравствуйте. При работе по TCP/IP (SCPI) с источником АКИП-1134-60-25 постоянно

наблюдается следующая проблема - в какой-то момент соединение зависает

(перестают приходить ответы на команды), при повторном соединении в ответ

на команду приходит ответ на предыдущую команду (в т.ч. из предыдущего соединения).



Пример (в данном случае для связи используется netcat, но, как показывает опыт,

при других способах наблюдается полностью аналогичная картина):
====code====
<s><#0></e>
=============
Здесь на SOUR:MODE? приходит ответ на *IDN? из предыдущего соединения,

а на следующую команду *IDN? приходит ответ на команду SOUR:MODE? И так

далее. Устранить эффект удаётся только выключением-включением

устройства. Не подскажете, есть решение этой проблемы? Может быть, есть

исправленная прошивка?



С уважением,

Иван

27.12.2016 10:47:04, ivan4th.]]>
http://prist.ru/forum/messages/forum4/topic2236/message13302/ http://prist.ru/forum/messages/forum4/topic2236/message13302/ Tue, 27 Dec 2016 10:47:04 +0300 Программное обеспечение