Корзина пуста

Генератор АКИП-3413/1 и LabVIEW

Страницы: 1
RSS
Генератор АКИП-3413/1 и LabVIEW
 
Добрый день!

Купили генератор сигналов специальной формы АКИП-3413/1. После подключения и установки драйверов в режиме USBRAW программа EasyWave видит генератор и прекрасно работает. При переходе на генераторе в режим USBTMC в диспетчере устройств компьютера появляется устройство USB Test and Measurement Devices (IVI) с восклицательным знаком. В свойствах говорится об отсутствии цифровой подписи у драйвера (скрин прилагается). Соответственно LabVIEW генератор не видит. Попытки переустановить драйвер, удалить его и заново установить результатов не дали. В чем может быть проблема, и как ее решить?
file.php (145.32 КБ)
 
Здравствуйте.



Операционная система какая?

Версия LabView какая?

Версия Measurement&Automation Explorer а попросту VISA какая?
 
Windows 7 professional x64

LabView 2012 (стоят обе версии 64-bit и 32-bit)

NI-VISA 14.0
 
Происходит то, что и написано. По непонятной причине не проверяется подпись.



Попробуйте отключить проверку подписи: http://winitpro.ru/index.php/2011/11/08/kak-otklyuchit-proverku-cifrovoj-podpisi-drajvera-v-windows-7/
 
Проверку подписи отключали практически сразу... Результат: передача данных от компьютера к генератору однократно срабатывает при отключении идентификатора очереди (queue ID). Т.е. генератор "вроде как" переключается в выбранный нами режим, однако Labview тут же вылетает (что, впрочем, естественно, поскольку нет обратной связи с генератором). Если queuе ID не отключать, то ошибка возникает сразу.

Собственно говоря, не совсем понятно, почему поставляемый с прибором драйвер не имеет цифровой подписи и, более того, даже при обходе проверки не работает.

Установка проводилась на трех компьютерах с Win 7-64 проф. Точнее, не установка, а попытка.
 
Прибор может работать в двух режимах. С собственным драйвером и с драйвером USBTMC.

Сделать так были свои причины.

Его ПО так же может работать с прибором в обоих режимах.



Но LabView может работать только тогда, когда прибор в режиме USBTMC.



Драйвер USBTMC производится той же фирмой, что и LabView - National Instruments.

И он подписан. Почему ваша операционная система не может проверить его подпись загадка.



Когда прибор в режиме USBTMC, проверка подписи отключена, восклицательный знак в диспетчере устройств пропадает?
 
Да, в диспетчере устройств воскл. знак пропадал, но симптомы - описанные выше.
 
Отлично.



Вот когда восклицательного знака нет. Запускаете Measurement&Automation Explorer, находите слева в разделе Devices and Interfaces ваш 3413,

и кликаете по нему.

После этого справа вверху появится кнопка Open Visa test panel. После нажатия на нее откроется окно.

В нем перейдете на вкладку Input/output и нажмете Query.



Я думаю прибор ответит на запрос.
 
Основная проблема - в том, что приходится входить по F8 для обхода проверки подписи драйвера. Другие методы не работают.
 
Надо писать в National Instruments (у них большое представительство в Москве) с вопросом почему на вашем ПК не проверяется подпись.



Возможно проблема в версии сборки или установленных/отсутствующих обновлениях.
 
Понятно. Спасибо...
 
Рад был помочь.
Страницы: 1
Читают тему

Войти в личный кабинет

Заказать обратный звонок

Обратите внимание, все поля - обязательны для заполнения.
Обновить

Обратная связь

Обратите внимание, все поля - обязательны для заполнения.
Обновить